Polaris Brutus Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a new, 2013 Brutus HD with the factory snow blade. I was able to use it the first time yesterday. When I went to put the blade down it stopped before hitting the ground. It was not caused by the shoes hitting first. It only went down all the way when I dropped the blade hard. On one occasions I moved the left "blade" switch and it dropped. I have read the manual 1/2 dozen times and I have found nothing. I was also told the blade would actually raise the front of the Brutus for back dragging. That's also not true, at least with mine.
Any ideas the forum has would be great appreciated.
 

·
Registered
Joined
·
327 Posts
Did you receive the snow blade owner's manual?

If everything is adjusted right, the snow blade can definitely lift the front wheels off the ground. Not that you should do this, but you can.

When I went to put the blade down it stopped before hitting the ground. It was not caused by the shoes hitting first. It only went down all the way when I dropped the blade hard.
Did the dealer provide the snow blade manual?

There are three pairs of adjustments for the blade -- THeleft/right angle switch, and two movements with the joystick -- up and down do the obvious, left and right adjust the "tilt cylinder".

Not to overstate something simple, but you need to use the left/right on the joystick to "level" (tilt) the blade so it just touches the ground.

Alternately, check the shear bolt? Anything else loose on the front end or the plow?
 
1 - 2 of 2 Posts
Top