Polaris Brutus Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Need some help kinda stumped.


2013 Brutus died while running and will not start.


I'll try to paint the picture.


The machine was running fine, and now that summer hit here in the upper midwest, cutting grass without AC is not an option.
With AC blowing hot air I changed out the high press cuttoff switch and recharged the AC with 24 oz of 134A.


After that took the machine for a ride with the AC on high, I noticed that there was a little decrease in overall power, top speed was ~30 mph in High Gear.


With the machine running on low idle and AC on low. I decided to fill it up and was intending on using the machine after that. During fuel fillup ( I did fill it RIGHT up to the top) the machine just shut down, and will not start back up.


Some troubleshooting that I have performed:


Replaced battery with brand new battery.
Opened the fuel injectors and it kinda drips out
Checked all fuses with meter no failures.


I'm out of ideas, please help with suggestions.


Thanks for your time


John
 

·
Registered
Joined
·
328 Posts
Find a copy of "Chapter_04_Fuel_System.PDF"

Try this: http://www.eserviceinfo.com/download.php?fileid=67124
With the machine running on low idle and AC on low. I decided to fill it up and was intending on using the machine after that. During fuel fillup ( I did fill it RIGHT up to the top) the machine just shut down, and will not start back up.
So you topped off the tank with the engine running?

When you say "will not start back up", what are the exact symptoms? How did you test the injectors (see below).
 

Attachments

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Thats correct, I topped off the tank with the engine running on low idle.


The motor turns over normal, just doesn't fire. I tried to spray carb cleaner in the air box, and it spun over faster however it wouldnt pop off.


All I did was loosen the nut for the fuel going into the motor on all three. However, It looks like "E" it just kinda drips out.
 
1 - 3 of 3 Posts
Top