Polaris Brutus Forum - Reply to Topic
Thread: New owner Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Polaris Brutus Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-09-2018 10:58 AM
LungsRT I have the same model and they named it Brutus for a reason, this machine is a workhorse. I unfortunately bought my 2013 from a person that didn't have a clue about maintaining a vehicle like this and by the time I bought it many things needed to be replaced right away. I had an electrical issue right from the start with my battery unable to hold a charge and a year later I'm still fighting this issue. I had the alternator checked which was fine, pumping out 90A just like it is suppose to. Bought a new battery but not the OEM and I discovered thru this forum that I probably didn't get the right battery for the charging rate of my alternator so I bought the OEM battery a month ago and it holds a charge much longer but still eventually discharges with use. I have a theory that my problem is related to when the radiator fan turns on and it puts a big drain on the battery, not sure why. The relay turns on and off appropriately and the engine cools efficiently but still a drain on the system. Nobody has been able to tell me why and I am left a bit frustrated because I cannot use it the way it was designed. I hope you are not experiencing the same issue but one thing I can guarantee, if you are looking for a machine to perform work and not to go bombing down the trail at 40mph you will not be disappointed. Do your maintenance and the engine will run forever! Good Luck.
03-01-2018 07:24 PM
thendrix
New owner

Just got a 2013 Brutus HD with the bucket. Going to be used on a commercial poultry farm. I run the farm for my in-laws and from what I understand this is more of what the machine was made for. At first use the bucket actually surprised me. It picked up a full bucket of river rock and sand with no hesitation. I understand the speed being a limiting factor on these machines but it certainly beats the Mule 610 that was traded in.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome